DNS Service Disruption Impacting Multiple Systems

Incident Report for Abusix

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 15:38 UTC

Update

We are continuing to investigate this issue.
Posted Apr 11, 2025 - 15:38 UTC

Investigating

We are currently investigating this issue.
Posted Apr 11, 2025 - 15:07 UTC
This incident affected: Abusix Mail Intelligence (Lookup, RSYNC, Cloud DNS).