AWS Route53 Query Issues (SERVFAIL Errors)
Incident Report for Abusix
Resolved
No further issues reported, so switching this to Resolved/Operational.
Posted Jan 23, 2024 - 09:45 UTC
Monitoring
This appears to have been caused by Amazon Route53 sending some unexpected responses during a migration. We're not seeing any issues with any public DNS servers now, but if you're still having issues, please flush the DNS cache of your nameserver and that should correct it. Please contact support@abusix.com if you are experiencing issues after that.
Posted Jan 22, 2024 - 19:51 UTC
Investigating
We are currently experiencing issues with AWS Route53, resulting in SERVFAIL errors for certain customers' queries.
Posted Jan 22, 2024 - 18:17 UTC
This incident affected: Abusix Mail Intelligence (Cloud DNS).