Abusix Mail Intelligence
Incident Report for Abusix
Resolved
This incident has been resolved.
Posted Dec 02, 2022 - 10:02 UTC
Investigating
We have a suspected hardware failure, listing and delisting are unavailable until this can be fixed.
Posted Dec 01, 2022 - 23:20 UTC
This incident affected: Abusix Mail Intelligence (Lookup, App, RSYNC, Cloud DNS).