Authentication service is unavailable

Incident Report for Abusix

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 09:17 UTC

Identified

We are currently experiencing issues with our third-party authentication services. We're actively working on resolving the problem as soon as possible.
Posted Mar 18, 2025 - 09:06 UTC
This incident affected: AbuseHQ (Web Application) and Abusix Mail Intelligence (Lookup, App).