Domain Blocklist: domains incorrectly listed.

Incident Report for Abusix

Resolved

This incident has been resolved.
Posted Aug 13, 2024 - 13:17 UTC

Monitoring

All domain data has been flushed; a fix has been applied and we are monitoring this fix now.
Posted Aug 13, 2024 - 06:06 UTC
This incident affected: Abusix Mail Intelligence (Lookup, App, RSYNC, Cloud DNS).