Hardware upgrade has been completed, and all services should be operating normally. We're monitoring the situation.
Posted May 17, 2024 - 15:56 UTC
Update
Service provider hardware upgrade has increased in scope and now it's affecting login services. We're looking into the issue and preparing further mitigations
Posted May 17, 2024 - 10:25 UTC
Identified
We're currently experiencing an outage caused by hardware upgrades at one of our data service providers. They have informed us that the service will be restored shortly.
We've implemented several mitigations, but the AMI statistics service will present degraded functionality until the upgrade is complete.
Posted May 17, 2024 - 09:58 UTC
This incident affected: AbuseHQ (Web Application) and Abusix Mail Intelligence (Lookup, App, RSYNC).