Incorrect listings on Exploit and AuthBL lists
Incident Report for Abusix
Resolved
All incorrect records have been purged now.
Posted Jul 27, 2022 - 10:42 UTC
Investigating
Overnight we received some bad data from a 3rd party supplier which has caused valid hosts to be incorrectly listed in the "exploit" and "authbl" lists. We're working on a fix and should have this deployed soon.
Posted Jul 27, 2022 - 07:48 UTC
This incident affected: Abusix Mail Intelligence (Lookup, App, RSYNC, Cloud DNS).