Abusix Mail Intelligence Backend
Incident Report for Abusix
Resolved
This incident has been resolved.
Posted May 10, 2022 - 15:57 UTC
Update
We are continuing to investigate this issue.
Posted May 10, 2022 - 15:56 UTC
Investigating
We are currently experiencing an issue on the backend of Abusix Mail Intelligence, this is causing some lookup slowness, delists are unavailable at this time and no zone builds are currently being run.
Posted May 10, 2022 - 14:24 UTC
This incident affected: Abusix Mail Intelligence (Lookup, App, RSYNC, Cloud DNS).